Degraded API Performance

Incident Report for Mews

Monitoring

Correction, please disregard the previous update as it was related to another incident: https://status.mews.com/incidents/3q6n596dqzd9
Posted Jul 16, 2025 - 17:26 CEST

Investigating

We have noticed a downgraded performance of the Smart Tips.
We are currently looking into it.
Thank you for your patience.
Posted Jul 16, 2025 - 16:56 CEST

Monitoring

We have resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Jul 15, 2025 - 17:48 CEST

Investigating

We are currently investigating reports of increased latency across our public API. Initial indicators show periodically elevated response times and timeouts affecting most endpoints.

Thank you for your patience as we work to resolve the issue.
Posted Jul 15, 2025 - 13:43 CEST
This incident affects: Mews Open API.