Connection issues with app.mews.com
Incident Report for Mews
Postmortem

Problem

Many clients were experiencing intermittent connection issues and very slow response times during a 5h time frame, West Europe was affected the most.

Action

We escalated this with Microsoft and cooperated with them during the investigation. We also explored a way of bypassing the faulty 3rd party component, but deemed it too risky.

Causes

Our cloud provider Microsoft Azure had global connectivity issues affecting their network routing technology Azure Front Door which Mews utilizes to route traffic.

Solutions

We will extend failover drills with the action that would bypass the faulty component, so that in case this happens again, we will be able to remediate sooner. Microsoft is also taking steps to prevent the root cause.

Posted Jul 04, 2022 - 11:14 CEST

Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 15:42 CEST
Monitoring
We are observing response times to be back to normal for the past 30 minutes. We continue to monitor the situation.
Posted Jun 14, 2022 - 13:53 CEST
Update
Microsoft Azure applied mitigation steps and we are seeing signs of recovery. We are closely monitoring the situation.
Posted Jun 14, 2022 - 13:36 CEST
Update
Microsoft Azure applied mitigation steps and we are seeing signs of recovery, but performance is still degraded. We are closely monitoring the situation.
Posted Jun 14, 2022 - 12:22 CEST
Update
Microsoft Azure applied mitigation steps and we are seeing signs of recovery. We are closely monitoring the situation.
Posted Jun 14, 2022 - 11:23 CEST
Update
Our cloud provider Microsoft Azure has confirmed an issue on their side. We are experiencing intermittent connection issues with app.mews.com in some EU regions and working with Microsoft on the resolution.
Posted Jun 14, 2022 - 11:06 CEST
Identified
We have identified an issue with our cloud provider Microsoft Azure, network traffic routing in some EU regions is affected. We are closely monitoring the situation and will provide further updates.
Posted Jun 14, 2022 - 09:57 CEST
Investigating
We are experiencing partial outage of app.mews.com.
Posted Jun 14, 2022 - 09:21 CEST
This incident affected: Operations, Guest Journey, Business Intelligence, Payments, Open API, and Marketplace.