Downgraded Performance

Incident Report for Mews

Resolved

The impact from the issue is over.
Reports are loading at normal speeds.

Thank you for your patience while we addressed this issue.
Posted Jan 30, 2026 - 10:46 CET

Monitoring

Ledger performance has returned to normal levels. Reports should load at expected speeds without timeouts.

Our engineering team continues to actively monitor the situation to ensure stability.

Thank you for your patience and understanding.
Posted Jan 27, 2026 - 18:01 CET

Investigating

We are currently experiencing degraded performance with our ledger services. Reports may take significantly longer to load or may timeout before completing.

Our engineering team is actively investigating the root cause and working to restore normal performance levels. We will provide updates as more information becomes available.
Posted Jan 27, 2026 - 17:05 CET