Support phone call integration is unavailable
Incident Report for Mews
Resolved
This incident has been resolved by the 3rd party provider. You can find more information on Aircall's status page - https://status.aircall.io/
Posted Nov 16, 2022 - 17:51 CET
Identified
Our support phone call integration is unavailable due to an outage of our 3rd party provider: https://status.aircall.io/
If you need to reach our support, please do so through email (support@mews.com) until this is resolved. We are sorry for any inconvenience this can cause for you. We will keep you updated.
Posted Nov 16, 2022 - 15:07 CET
This incident affected: Aircall Inbound calls.