Ledgers not available

Incident Report for Mews

Resolved

The issue is now fully resolved. Ledgers are now operating as expected.
Posted Jan 08, 2026 - 12:06 CET

Monitoring

For a short period of time, Ledgers were not available in Mews. The underlying issue has been identified and resolved, and Mews is now operating as expected.
We’re continuing to monitor the system, but no further impact is expected.
Posted Jan 08, 2026 - 10:56 CET
This incident affected: Mews Operations.