Data Processing Delays - Mews BI Affected

Incident Report for Mews

Resolved

We confirmed the Mews BI data is being refreshed as expected.
Posted Mar 10, 2026 - 17:22 CET

Monitoring

The data was just refreshed. We're monitoring the data pipeline performance.
Posted Mar 10, 2026 - 13:33 CET

Update

The data is still being processed. We expect the data to be refreshed less than 20 minutes.
Posted Mar 10, 2026 - 13:26 CET

Identified

Our data processing infrastructure is running behind which is causing lagged data in Mews BI. No data has been lost and the system should be caught up in 1 hour.
Posted Mar 10, 2026 - 12:14 CET
This incident affected: Mews Business Intelligence.