All inventory updates from Expedia are failing.

Incident Report for Mews

Resolved

Expedia has resolved their outage. Inventory updates from Mews to Expedia are back to normal.
Posted Jun 25, 2026 - 13:24 CEST

Monitoring

Expedia is currently experiencing an outage. Inventory updates from Mews to Expedia are failing, but reservation flows are unaffected. We are actively monitoring and will provide updates as the situation develops.
Posted Jun 25, 2026 - 11:44 CEST
This incident affected: Mews Operations and Mews Marketplace.