Issue with Mews Reservation with wrong VAT

Incident Report for Mews

Resolved

The issue has been resolved. All affected properties have been notified with guidance on how to proceed regarding closed invoices. Impacted future bookings have been corrected and are no longer affected.
Posted Oct 03, 2025 - 18:44 CEST

Identified

We identified an issue with a recently introduced feature in Rate Management that impacted override pricing. This caused incorrect VAT/Tax rates to be applied to items with overrides.

The feature has now been disabled, and we are deploying a fix to prevent any new reservations from being created with incorrect VAT/Tax rates.

We are also identifying existing reservations that were affected.
Further updates will be shared here as we progress.
Posted Sep 17, 2025 - 01:22 CEST
This incident affected: Mews Operations.