Downgraded Performance: some customers are unable to add products to carts

Incident Report for Mews

Postmortem

Problem

On July 14, 2025, some properties experienced difficulty adding products to orders due to a system configuration change that required additional setup data.

Action

We immediately identified the missing configuration data and provisioned the required records for all affected properties. Users were instructed to restart their applications to receive the updates.

Causes

A feature activation was deployed without ensuring all necessary supporting data was in place across all merchant accounts.

Solutions

  • Provisioned missing configuration data for all affected merchants.
  • Implemented validation checks to prevent similar data dependency issues.
  • Enhanced our deployment process to verify data requirements before feature activations.
Posted Aug 14, 2025 - 17:34 CEST

Resolved

The issue is now fully resolved. Mews is now operating as expected. Please resync your app by restarting it.
Posted Jul 14, 2025 - 14:03 CEST

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Jul 14, 2025 - 13:19 CEST
This incident affected: Mews POS.