Mews POS Unplanned Outage - we are working hard on a solution

Incident Report for Mews

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 09:25 CEST

Identified

Mews POS experiencing an unplanned outage.
We are working on solving this problem as quickly as possible.
Please continue checking this page for updates on the status.
Posted Aug 27, 2025 - 09:13 CEST
This incident affected: Mews POS.