Impossible to take payment
Incident Report for Mews
Resolved
The impact from the issue is over.
Posted Nov 15, 2024 - 20:39 CET
Monitoring
Properties are not able to process payments, "Unexpected Error" message comes up.
Posted Nov 15, 2024 - 17:58 CET
This incident affected: Payments.