Booking Engine experiencing issues

Incident Report for Mews

Resolved

Since all Booking Engines are now working, although without the new Upsell feature, we will be closing this incident. Thank you for your patience and understanding.
Posted Jan 15, 2026 - 19:02 CET

Update

We are still trying to fix the issue, as it is related to the new Upsell feature, we have temporarily disabled this new feature; Booking Engine will be using the old promotions configuration in the interim. Apologies for the inconvenience, and thank you for your patience.
Posted Jan 15, 2026 - 18:10 CET

Update

We are still working to fix the issue. Thank you for your patience
Posted Jan 15, 2026 - 17:37 CET

Update

We are still working on resolving the issue. Thank you for your patience.
Posted Jan 15, 2026 - 16:44 CET

Identified

We have identified the issue and are working on to resolve it
Posted Jan 15, 2026 - 16:04 CET

Investigating

We've spotted issues with the Booking Engine. We're currently investigating the issue, and will provide an update soon.
Posted Jan 15, 2026 - 15:32 CET
This incident affected: Mews Guest Experience.