Bill closing and check-out issues for properties in Austria using the Chaining fiscal registry integration

Incident Report for Mews

Postmortem

Problem
On 1 August 2026 at 00:00 Central European Summer Time, properties in Austria using the Chaining fiscal registry integration could not close bills or complete guest check-outs. Affected properties saw the message "Cannot close bills because of fiscal registry constraints" when closing any bill that included a cash or card payment. The issue affected at least 181 properties and blocked 1,621 bills.

Action
Austrian properties and our Support team raised the issue at 07:49 Central European Summer Time. We identified the cause and applied a fix at 10:00 Central European Summer Time, which immediately restored bill closing and guest check-outs.

Causes
A background process prepares the monthly fiscal records that Austrian properties need in order to close bills. One property's account status changed twice, from active to deactivated and back again, and this left that property's fiscal records incomplete. The process handled every Austrian property in a single batch, so this one property stopped it from preparing records for all the others. The failure became visible at the start of August, when properties needed the new month's records.

Solutions
We restored fiscal record generation for all active Austrian properties at 10:00 Central European Summer Time and confirmed full recovery at 11:01 Central European Summer Time. The system is fully operational, properties can now close every bill affected during the incident, and we did not lose any data. We are adding dedicated monitoring and alerting to this process, introducing health checks at each month boundary, and redesigning it so one property can no longer block the others.

We know that blocked check-outs during the morning departure wave put front desks under real pressure, and we are sorry for the disruption this caused you and your guests.

Posted Aug 07, 2026 - 15:14 CEST

Resolved

Between 00:00 and 09:15 CEST on 1 August, properties in Austria were unable to close bills and check out guests due to an issue with the Austrian fiscal registry integration. The issue has been identified and resolved, and bill closing and check-outs are working normally again. No data was lost, and any bills affected during this period can now be closed as usual — no further action is needed.

We apologize for the disruption this caused during morning check-outs.
Posted Aug 01, 2026 - 11:05 CEST

Monitoring

We identified an issue affecting some properties in Austria that prevented bills from being closed. The issue has been resolved, and we are closely monitoring the system to ensure continued stability.

We apologize for any inconvenience this may have caused.
Posted Aug 01, 2026 - 09:57 CEST

Investigating

Austria — bills cannot be closed for some properties

We are investigating an issue affecting some properties in Austria where bills cannot be closed. The issue is related to the fiscal registry integration and does not affect reservations, payments, or any other part of the system.

Affected properties will see an error when attempting to close a bill.

We are working to identify the full scope of impact and will post an update shortly.
Posted Aug 01, 2026 - 08:47 CEST
This incident affected: Mews Operations.