Degraded performance
Incident Report for Mews
Resolved
This incident has been resolved.
Posted May 16, 2022 - 13:36 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 16, 2022 - 12:35 CEST
This incident affected: Operations, Guest Journey, Business Intelligence, Payments, Open API, and Marketplace.