Mews unavailable
Incident Report for Mews
Postmortem

Problem

After deploy and running any operations related to any reservations coming from channel manager database got overloaded so the whole Mews become significantly slowed down.

Action

We found out there wasn't optimized database operation, so we rolled back deployment to the previous version which took 4 minutes.

Causes

Ineffective searching in the database was used in many places where it wasn't necessary.

Solutions

Every extension of the database table will require included optimization.

Posted Oct 07, 2022 - 08:15 CEST

Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 17:37 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2022 - 16:45 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 15, 2022 - 16:42 CEST
Investigating
We are currently investigating the issue of the system being unavailable.
Posted Sep 15, 2022 - 16:40 CEST
This incident affected: Operations, Guest Journey, Business Intelligence, Payments, Open API, and Marketplace.