Unplanned Outage of Mews web app

Incident Report for Mews

Resolved

We observed localised spikes in latency, customers might have experienced slow loading pages, and low responsiveness.

Mews is now operating as expected.
Posted Feb 12, 2026 - 17:58 CET

Update

We have scaled our infrastructure and the service is now operational, but we are still investigating the root cause.
Posted Feb 12, 2026 - 16:59 CET

Investigating

We are currently experiencing an unplanned outage.
We are working on solving this problem as quickly as possible.
Please continue checking this page for updates on the status.
Posted Feb 12, 2026 - 16:34 CET
This incident affected: Mews Operations.