Supported browsers update

Scheduled for Jun 25, 14:05 CEST  -  Jul 2, 14:05 CEST

Update

All services remain fully accessible.
Posted Jun 25, 2025 - 14:01 CEST

Scheduled

Following release note from last week https://releases.mews.com/en/better-security-with-updated-browser-support-qOYZO38R, Mews is updating its list of supported browsers, starting effectively from today. Users are encouraged to utilise the latest versions of Google Chrome or Microsoft Edge, since Safari versions prior to 15 will no longer be supported. This update is designed to enhance security and improve performance for all users. For further information on compatible browsers, please refer to our help article https://help.mews.com/s/article/what-is-the-best-browser-for-mews?language=en_US.
Posted Jun 25, 2025 - 14:00 CEST
This scheduled maintenance affects: Mews Operations and Mews Guest Experience.