Issue with reservation assignment
Incident Report for Mews
Investigating
We are investigating an issue with booking.com reservations. This is affecting only a small subset of hotels with a direct booking.com integration. We are working on a solution and will update affected customers shortly.
Posted Nov 19, 2024 - 11:40 CET