Downgraded Performance in the German region
Incident Report for Mews
Resolved
A few properties in the German region were reporting an issue with Mews being slow or that they cannot log in,

After some investigation, we concluded these issues were caused by Internet Service Provider problems and not Mews. These problems have since been resolved.
Posted Jan 12, 2024 - 16:10 CET
Investigating
We have received reports of downgraded performance of the system.
We are currently investigating
Thank you for your patience.
Posted Jan 12, 2024 - 14:38 CET
This incident affected: Operations.