PCI proxy is under maintenace

Incident Report for Mews

Resolved

Maintenance finished at 7AM CEST

During the maintenance window we observed two brief periods of unavailability, causing minor performance degradation.

https://status.pci-proxy.com/incidents/n69s4w500835
Posted Jun 22, 2025 - 09:33 CEST

Monitoring

PCI proxy is under maintenance.
During this window you may notice:

Payment processing: intermittent delays or temporary failures

Channel Manager reservations: possible delivery delays

We are actively monitoring performance and will post updates as soon as the maintenance is complete.
Posted Jun 22, 2025 - 04:46 CEST