Delay in April Subscription and Commission Invoices

Incident Report for Mews

Update

Our team is continuing to work diligently to resolve the issue. We understand how important these documents are for your financial operations and sincerely apologize for the continued inconvenience. Resolving this matter remains a top priority, and we will notify you immediately once the invoices are available.
Posted May 12, 2025 - 13:24 CEST

Identified

We are currently experiencing delays in the delivery of Mews Subscription and Payment Commission invoices for April.

Our team is actively working to resolve the issue and ensure all invoices are sent out as soon as possible.

We understand the importance of timely invoicing and apologise for any disruption this may cause to your operations. Thank you for your patience and understanding.
Posted May 08, 2025 - 10:26 CEST