Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 29, 2026 - 03:00 CEST
Scheduled
Our PCI compliance partner will be under maintenance. https://status.pci-proxy.com/incidents/vv5q6vsc0h3w This can disrupt the reservation delivery from distribution partners. If you are missing reservations from your distribution partners after this period, reach out to your distribution partner for resending reservations to Mews.
Posted Apr 28, 2026 - 13:49 CEST
This scheduled maintenance affected: Mews Marketplace.