Broad Internet issues (Mews PMS unaffected)

Incident Report for Mews

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 09:42 CEST

Monitoring

Multiple cloud providers and services are reporting disruptions and outages at the moment. Mews PMS remains unaffected, but our teams continue to monitor.
Posted Jun 12, 2025 - 21:58 CEST