Issues with Mews Booking Engine

Incident Report for Mews

Postmortem

Problem

An issue was identified in the booking engine where the second step of the booking process (category selection) failed when at least one room was unavailable.

Action

We promptly redeployed the last stable version of the booking engine to restore functionality while investigating the root cause.

Causes

The issue was introduced by a recent change aimed at supporting US fee descriptions, which unintentionally caused a bug in the booking flow.

Solutions

  • The bug in the booking computation has been fixed.
  • We are actively improving our alerting and monitoring systems to better detect and address similar issues before they affect users.
Posted Jun 18, 2025 - 16:11 CEST

Resolved

We found the problem with the Booking Engine, and deployed a fix. It should be working for everyone now.
Posted Jun 09, 2025 - 14:41 CEST

Investigating

We are currently investigating reports of an issue affecting the Mews Booking Engine. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Jun 09, 2025 - 14:01 CEST
This incident affected: Mews Guest Experience.