We are still monitoring the pending queue items, but updates are still being sent with some delay. We’re monitoring the system closely and keeping an eye on the processing times.
Posted Aug 22, 2026 - 21:41 CEST
Monitoring
The queue is clearing slowly, but updates are still being sent with some delay. We’re monitoring the system closely and keeping an eye on the processing times.
Posted Aug 22, 2026 - 20:27 CEST
Identified
Updates to availability, rates and restrictions sent from Mews to Booking.com began to be delayed at 14:00 CEST today. We traced the cause to slow and failing responses from Booking.com's rates and availability service, and we have contacted Booking.com. Properties with a Booking.com connection may see recent changes take longer than usual to appear.