Printing bills in Germany experiencing issues

Incident Report for Mews

Postmortem

Problem

Properties in Germany using the fiscalization integration were unable to print bills between January 20, 2026 (13:18 UTC) and January 21, 2026 (02:03 UTC). The fiscal signing process required for German tax compliance was not completing during bill closure.

A related incident occurred on January 26, 2026, affecting properties in Germany and France for approximately one hour (14:01 - 14:55 UTC). Invoice previews displayed a "waiting for fiscal registry confirmation" message and PDF generation was delayed.

Causes

A database performance issue caused the system to time out when processing German fiscal records. The database query optimizer selected an inefficient execution path, which prevented fiscal records from being processed in a timely manner. This was an infrastructure-level issue unrelated to any software release or scheduled maintenance.

The January 26 incident had the same root cause: outdated database index statistics caused the query optimizer to select an inefficient execution path.

Action

Our engineering team identified the database performance issue and restored optimal query performance. All pending fiscal records were processed successfully and no data was lost. The service was fully restored on January 21, 2026, at 02:03 UTC.

For the January 26 incident, the team applied a similar fix and confirmed resolution by 14:55 UTC. All affected records were processed successfully.

Solutions

We are implementing the following measures to prevent recurrence:

Enhanced monitoring and alerting for fiscalization processing performance

Database query optimizations to improve resilience

Infrastructure improvements to ensure consistent query performance

We apologize for any inconvenience this disruption may have caused. Please contact our support team if you have any questions.

Posted Feb 02, 2026 - 13:22 CET

Resolved

The issue has been resolved. Fiscalization of pending invoices has completed successfully, and the system is operating normally.
Posted Jan 21, 2026 - 03:19 CET

Investigating

We're experiencing errors/delay to print Bills in Germany for customers using fiscalization integration.
Posted Jan 20, 2026 - 23:31 CET
This incident affected: Mews Operations.