We've gone through the logs for the pricing services and we can confirm all calls are processing as expected now.
All of the failing operations, like those related to reservations are now processing succcessfully.
Posted Aug 24, 2025 - 06:42 CEST
Monitoring
All is operational again and check-in/check-out flow issues should be resolved.
An issue was identified with the Pricing Service in the production environment, impacting reservation-related actions dependent on the price matrix. The team investigated and implemented corrective actions, including restarting and reconfiguring the affected service. Additional scaling measures were applied to ensure stability and improve throughput.
Following these steps, application and API performance has returned to normal levels, and the Pricing Service is operating as expected.
Posted Aug 24, 2025 - 06:34 CEST
Investigating
We have identified an issue affecting check-ins, check-outs, and creating new reservations. Our R&D team is currently investigating the cause. We will provide an update as soon as we know more.
Posted Aug 24, 2025 - 05:46 CEST
This incident affected: Mews Operations, Mews Guest Experience, and Mews Open API.