Bill contains wrong assignee data
Incident Report for Mews
Resolved
This incident has been resolved.
Posted Sep 01, 2022 - 19:54 CEST
Monitoring
A fix has been deployed and we're continuing to monitor the situation.
Posted Sep 01, 2022 - 16:40 CEST
Investigating
We have noticed an issue where the bill close page opens without the up-to-date data for the bill assignee. It can be the first name of a customer is missing or the address is not up-to-date with the customer profile. Please pay close attention to the assignee data on that page and don't close bills if anything is missing. We're working on an immediate fix and then there will be communication about what to do about the already closed bills.
Posted Sep 01, 2022 - 12:00 CEST
This incident affected: Operations.