Channel manager synchronization issues
Incident Report for Mews
Postmortem

Problem

A number of clients were experiencing an outage in the processing of availability, price, and restrictions updates through the channel managers. Later many other clients started experiencing an outage in processing incoming reservations as well.

Action

We increased the processing capacity during the investigation. We ran a job that did fix the processing of availability, price, and restrictions updates, but broke the reservation processing. We found a pattern in the unprocessed incoming reservations and manually fixed it in production.

Causes

The change in our processing jobs was not automatically applied and the reset to apply the change broke the setting of our processing jobs.

Solutions

We will fix our setting for the processing job and create an automatic test for them. We will make queue monitoring more accurate and easier to identify errors. This will also include automatic early notification for our team

Posted Sep 07, 2022 - 10:01 CEST

Resolved
The problem was resolved and all operations are back to normal.
Posted Jul 20, 2022 - 15:14 CEST
Monitoring
We resolved the problem and we are already seeing significant improvement. Still continuing with monitoring of queue.
Posted Jul 20, 2022 - 14:48 CEST
Update
We resolved the problem and we are already seeing significant improvement. Still continuing with monitoring of queue.
Posted Jul 20, 2022 - 14:47 CEST
Identified
We are currently experiencing processing issues with the transfer of inventory and reservation information via channel manager connections since 2AM CET 20/7/2022

We have identified an issue and we are working on the fix of it.
Posted Jul 20, 2022 - 13:47 CEST
This incident affected: Operations, Open API, and Marketplace.