Online payments failing
Incident Report for Mews
Resolved
Dear customers,

There hasn't been any online payments related downtime since October 14th 20:50 CEST, so we consider the issue as resolved.

Our PCI Proxy provider is investigating the root cause.

Best Regards,
Mews
Posted Oct 15, 2024 - 07:56 CEST
Monitoring
A third party PCI Proxy used to meet PCI compliance requirements had an degraded service between 8 - 9 PM CET. This led to failures during online payment flows.

PCI Proxy has recovered and we are monitoring the situation.
Posted Oct 14, 2024 - 21:44 CEST
This incident affected: Payments.