Booking.com reservations outage.

Incident Report for Mews

Resolved

Booking.com has resolved the outage. Reservations are now successfully being created in Mews.
Posted May 21, 2026 - 15:48 CEST

Monitoring

Booking.com is experiencing outage for reservations delivery.
No reservations for booking.com direct integration are currently created in Mews.
We are monitoring the situation.
Posted May 21, 2026 - 12:57 CEST
This incident affected: Mews Marketplace.