Chat & Communications to Support

Incident Report for Mews

Resolved

Our provider, Salesforce, has confirmed that the issue affecting our chat functionality and ticket creation has been resolved.

If you continue to experience any issues please reach out to us via phone. Thank you for your patience.

You can find more information directly on Salesforce status page: https://status.salesforce.com/incidents/13729
Posted Feb 14, 2025 - 02:21 CET

Identified

We are currently experiencing intermittent issues with our Chat support and Help centre, due to an ongoing incident on our tooling provider's side.

This may affect being unable to get in contact with our Support team.

Our provider, Salesforce, has acknowledged the issue and is actively working on a resolution.

In the meantime, we encourage you to reach out via chatbot, email or phone for urgent matters. We apologize for the inconvenience and appreciate your patience while this is being resolved.

We will provide further updates as soon as more information becomes available.
Thank you for your understanding.
— Mews Support Team
Posted Feb 14, 2025 - 01:08 CET