The issue is now fully resolved. Mews is now operating as expected.
Posted Nov 19, 2025 - 16:32 CET
Identified
The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Nov 19, 2025 - 16:05 CET
Investigating
We are currently investigating reports of an issue affecting Mews Homepage Dashboard in Spanish properties. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.