Delayed delivery of webhooks

Incident Report for Mews

Resolved

The backlog of events has been processed and webhooks delivery is back to normal.
Posted Dec 17, 2025 - 21:33 CET

Monitoring

The recovery of webhooks delivery continues, full recovery expected within 3 hours.
Posted Dec 17, 2025 - 19:38 CET

Update

We took steps to mitigate the impact and sending of delayed webhooks has resumed. We are monitoring the improvement and will take additional steps to increase the recovery speed.
Posted Dec 17, 2025 - 18:14 CET

Update

We took initial steps to resolve the issue, but the webhooks processing is still partially stuck for the following event types: ServiceOrderUpdated, MessageAdded, PaymentUpdated.

We will update you soon on further progress.
Posted Dec 17, 2025 - 16:12 CET

Identified

We have identified the cause for the delays and now we are taking steps to restore the webhooks delivery performance.
Posted Dec 17, 2025 - 14:35 CET

Investigating

We are investigating delayed delivery of approximately 9% of webhooks, which may be delayed up to 3 days.
Posted Dec 17, 2025 - 14:05 CET
This incident affected: Mews Open API.