Integration partners not being able to process reservation updates
Incident Report for Mews
Postmortem

Problem

We have been performing a migration during which we updated a large number of reservations in a short time. Some of our integration partners are batching reservation updates by fetching updates from a fixed update date interval. Since there is a limit to the number of updates they can process in one batch, their reservation update processing was blocked.

Additionally, some properties using the Reservation report with the filter on update date were unable to use the report because the number of returned reservations exceeded the report limit.

Action

We have reprocessed all the migrated reservations and changed (only) their update date so that the updates are more distributed over time.

Causes

  1. Our integration partners don't use pagination but use update date intervals instead.
  2. The reservation report displays the "Number of reservations in report exceeds max quota of 10000." error to the user and doesn't let them know how to change the filtering to see the data.

Solutions

  1. We have changed our approach to internal migrations not to allow rapid changes of a large number of entities.
  2. Eventually, all our partners will need to start using pagination.
  3. Our reports will display more helpful error messages to the user.
Posted Sep 22, 2022 - 17:07 CEST

Resolved
We are currently investigating this issue.
Posted Jun 01, 2022 - 17:00 CEST