No data available in new reservation screen
Incident Report for Mews
Postmortem

Problem

On 2023-01-06 11:01:05 UTC the new reservation screen in Mews Operations started displaying a message: "No data available" in the Availability section for every occupancy configuration except the default 2 adults' configuration. This prevented Mews customers from being able to create reservations with non-default occupancy.

Action

We identified that the root cause was a discrepancy between data query from the New reservation screen with the data returned by the API. We then reverted the code changes responsible for this issue to the previous state.

Causes

The accommodation prices of age categories in reservations that didn’t have any persons in those age categories were not being transferred between system components.

Solutions

We will extend testing scenarios to prevent similar issues in the future.

Posted Jan 24, 2023 - 09:51 CET

Resolved
Our monitoring shows that this incident has been resolved. We apologize for any inconvenience it may have caused.
Posted Jan 06, 2023 - 18:56 CET
Monitoring
Fix was delivered to all our clients and environments. We will continue to monitor the impact.
Posted Jan 06, 2023 - 17:46 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 06, 2023 - 17:43 CET
Identified
Root cause of the issues was identified. Fix is being verified and awaits deployment for all clients.
Posted Jan 06, 2023 - 15:59 CET
Investigating
Currently, when trying to change occupancy from the standard, the reservation screen returns no available data. We are investigating the root cause and will update you regularly on our progress.
Posted Jan 06, 2023 - 15:10 CET
This incident affected: Operations.