Partner that handles payments for has resolved their issues.
Channel manager reservation delivery now fully operational. Summary: Issues: Reservations not delivered to Mews or delayed Mitigation: Missing reservations were refetched and partners notified to repush missing reservations.
Payment processing now fully operational Summary: Issues: Not possible to add cards and online payments failing Charging cards stored in PCI Proxy Mitigation: Payments processed after the incident Adding cards temporarily disabled
Posted Jun 25, 2025 - 11:53 CEST
Update
We are seeing ongoing issues with one of our external partners who handles payment for us. We are actively monitoring and troubleshooting, and the payment partner is working to resolve the root cause. We are attempting to minimise the impact to our Mews customers, though there may be some stability issues with payments and reservations during this time. We will work to mitigate or remediate anything that we observe quickly.
Posted Jun 23, 2025 - 13:46 CEST
Monitoring
PCI proxy confirmed services are back online. New reservations from channel managers are being created. Payments are being processed successfully.
Posted Jun 23, 2025 - 13:26 CEST
Identified
PCI proxy is experiencing outage thus new reservations from channel managers aren't created and payments are failing.
Posted Jun 23, 2025 - 13:23 CEST
This incident affected: Mews Payments and Mews Marketplace.