Data Processing Delays - Mews BI Affected

Incident Report for Mews

Resolved

We confirmed the Mews BI data is being refreshed as expected.
Posted Mar 25, 2026 - 13:24 CET

Identified

Our data processing infrastructure is running behind which is causing lagged data in Mews BI. No data has been lost and the system should be caught up in 1 hour.
Posted Mar 25, 2026 - 12:08 CET