Report schedules are not sending attachments in mails

Incident Report for Mews

Postmortem

Problem

  • On Monday 22.07.2024 at 3:52 UTC, the system began sending emails for scheduled report exports without attachments. As a result, the recipients did not receive their periodic report exports.

Action

  • The engineering team promptly identified the source of the issue, resolved it, and deployed a new version of the application.
  • The engineering team also identified the affected emails that were sent to recipients without attachments and resent those with a weekly or longer periodicity.

Causes

  • A bug in the code responsible for creating export emails was introduced by earlier changes.

Solutions

  • Enhance test coverage to automatically identify similar issues in the future.
  • Refactor outdated code to ensure safer modifications.
Posted Jul 29, 2024 - 13:07 CEST

Resolved

We think the impact from the issue is over.
Posted Jul 15, 2024 - 18:42 CEST

Identified

We're identified root cause and team started working on a fix.
Posted Jul 15, 2024 - 16:41 CEST