Data Processing Delays - Reporting Tools Affected

Incident Report for Mews

Postmortem

Problem

  • On Monday 27.11.2023 at 9:50 UTC a scheduled production deployment introduced a misconfiguration of Mews background processing, causing delays in channel manager notifications, payments and notifications from integration partners.

Action

  • We rolled back to the previous version and the processing fully caught up at 11:08 UTC.

Causes

  • Incorrect configuration on our primary background processing infrastructure reduced the throughput to about 5%.

Solutions

  • Measures will be implemented to improve the visibility of infrastructure configuration changes. Additionally, steps are being taken to improve application resilience.
Posted Dec 06, 2023 - 11:07 CET

Resolved

A recent change was causing high utilization of our background processing, causing delays in processing channel manger notifications, payments and notifications from integration partners. We have reverted back to previous version and data processing caught up shortly after.
Posted Nov 27, 2023 - 18:36 CET

Monitoring

We have identified a recent change that was causing high utilization of our background processing. We have reverted back to previous version and data processing is catching up.
Posted Nov 27, 2023 - 12:02 CET

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. We are investigating and will provide update shortly.
Posted Nov 27, 2023 - 11:51 CET
This incident affected: Mews Operations, Mews Guest Experience, Mews Business Intelligence, and Mews Payments.