Issue with Mews

Incident Report for Mews

Resolved

We have successfully identified and deployed a fix for the incorrect application of the city tax in Barcelona.
Systems are now calculating the tax correctly, and normal operations have resumed.
We apologize for any inconvenience caused.
Posted Apr 01, 2026 - 11:16 CEST

Identified

We are currently aware of an issue resulting in the incorrect application of the city tax in Barcelona. We are working on a resolution.
We will provide a further update shortly.
Posted Apr 01, 2026 - 10:17 CEST
This incident affected: Mews Operations.