We are currently preparing and deploying a synchronization job that will update all prices across the different channel manager platforms. We will provide another update as soon as the process has been completed or if we have any significant changes to share
Posted Mar 04, 2026 - 21:02 CET
Update
Incorrect price inventory updates for channel manager integrations for multi-level rates were synced during the incident (from 2PM CET to 5:30 PM CET). We are working on recovery.
Posted Mar 04, 2026 - 19:45 CET
Update
Incorrect price inventory updates for channel manager integrations for multi-level rates were synced during the incident (from 2PM CET to 5:30 PM CET). We are working on recovery.
Posted Mar 04, 2026 - 19:37 CET
Monitoring
The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Mar 04, 2026 - 17:36 CET
Update
The Mews team has identified and resolved the issue and will be deploying the fix shortly.
Posted Mar 04, 2026 - 16:21 CET
Identified
The Mews team identified the issue and is working on a resolution. Further updates will follow as we make progress.
Posted Mar 04, 2026 - 15:42 CET
This incident affects: Mews Operations and Mews Marketplace.