Unable to receive reservations due to PCI proxy outage

Incident Report for Mews

Resolved

Reservations are now going through.
PCI proxy has resolved the issue.
https://status.pci-proxy.com/incidents/39pvswc729g9

We are contacting affected partners.
Recovery of potentially lost reservations for Booking.com Direct has finished.
Posted Jun 20, 2025 - 11:11 CEST

Update

Posted Jun 20, 2025 - 10:52 CEST

Update

Payment processing is impacted as well.
Posted Jun 20, 2025 - 10:45 CEST

Monitoring

PCI Proxy is experiencing outage due to which mews can not receive incoming reservations
Posted Jun 20, 2025 - 10:41 CEST
This incident affected: Mews Operations and Mews Marketplace.