Unplanned Outage - search by confirmation number
Incident Report for Mews
Resolved
The search by confirmation number is back again.
Posted Jul 18, 2024 - 03:39 CEST
Investigating
We are currently experiencing an unplanned outage when users search for reservations by confirmation number.

We are working on solving this problem as quickly as possible.
Please continue checking this page for updates on the status.
Posted Jul 18, 2024 - 02:50 CEST
This incident affected: Operations.