Increased number of 3D Secure requests for payments, contributing to current issues with transactions stuck in verifying status
Incident Report for Mews
Resolved
The problem was resolved and new payments are not affected. Existing payments with already requested 3DS verification must be verified or they will be canceled.
Posted Sep 20, 2024 - 01:07 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2024 - 00:45 CEST
Investigating
We are currently investigating this issue.
Posted Sep 19, 2024 - 21:38 CEST
This incident affected: Payments.