The issue is now fully resolved. Mews is now operating as expected.
Posted Sep 06, 2025 - 15:25 CEST
Investigating
We are currently investigating reports of an issue causing the exports and export schedules failing to load. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Sep 06, 2025 - 13:50 CEST
This incident affected: Mews Business Intelligence.