Payment Processing Issue with Stripe Terminals

Incident Report for Mews

Postmortem

Problem

On 2024-02-12 11:05:24 (UTC), one of our internal tools unlinked PSP accounts with Mews customer accounts. This resulted in payment failures due to missing presence of PSP accounts. We successfully corrected the links and restored the system by 2024-02-12 14:12 (UTC).

Action

We restored the lost data and linked back the PSP accounts to Mews customer accounts using database backups.

Causes

The issue occurred due to the tool running unexpectedly through an automation. The tool has been removed from the code base preventing it from executing again.

Solutions

We have unblocked all payments, and we have restored the links to the PSP accounts as a result of our recovery efforts.

We are sorry for the inconvenience and we thank you for your patience as we work to keep the system reliable.

Posted Dec 06, 2024 - 13:06 CET

Resolved

The issue causing error messages when charging payments through Stripe Mews terminals has been fully resolved as of December 2, 16:12 CET. Thank you for your patience while we worked to address this.
Posted Dec 02, 2024 - 16:12 CET

Investigating

We have had some properties advising of an error message when trying to charge payments through Stripe Mews terminals
We are currently looking into this.
Thank you for your patience while we investigate.
Posted Dec 02, 2024 - 14:36 CET
This incident affected: Payments.