Unplanned Outage of app.mews.com
Incident Report for Mews
Postmortem

Problem

On January 21th at 8:35 AM UTC Mews Operations and other services such as the Mews Booking Engine, Mews Online Guest Services became unavailable caused by issues with the underlying service operated by the Mews cloud provider Microsoft Azure. The service was unavailable or degraded until 9:25 AM UTC.

Causes

The downtime was caused by an incident in the Mews hosting service provided by Azure, which prevented the application from scaling to match increasing demand.

Action

The Mews Platform team moved the impacted service to a different cloud region and restored availability.

Solutions

The underlying incident with the Mews cloud provider Microsoft Azure was resolved. The Mews team is evaluating options to mitigate such problems faster in the future.

Posted Jan 22, 2024 - 16:54 CET

Resolved
Our cloud provider has confirmed, that the issue has been resolved. The application is operating normally.
Posted Jan 21, 2024 - 14:01 CET
Monitoring
We await confirmation from our cloud provider regarding the final resolution of the the underlying issues. Our team continues to monitor system’s status.
Posted Jan 21, 2024 - 12:36 CET
Identified
This outage is caused by problems with the underlying hosting platform operated by our cloud provider. We have taken steps to mitigate the issue.
At the moment the application is available, but can still occasionally display errors.
Posted Jan 21, 2024 - 10:43 CET
Investigating
We are currently experiencing an unplanned outage of app.mews.com.
We are working on solving this problem as quickly as possible.
Please continue checking this page for updates on the status.
Posted Jan 21, 2024 - 10:13 CET
This incident affected: Operations and Guest Journey.