Properties cannot print fiscalization bills

Incident Report for Mews

Postmortem

Problem

On April 9, 2026, properties in France and Germany were unable to reliably print or download invoices due to issues with fiscal record processing.

  • In France, printing bills and invoices was blocked.
  • In Germany, printing was delayed, with documents available after a two-minute fallback.

Causes

A database performance issue caused fiscalization jobs in France and Germany to time out.
The database selected a suboptimal execution plan for a key query, which prevented fiscal records from being processed and blocked invoice generation.
This was an infrastructure issue and was not caused by a recent code release.

Action

Our engineering team identified the affected queries and restored normal database performance, unblocking fiscalization jobs in both countries.
All pending fiscal records for France and Germany were processed by 09:41 CEST on April 9, 2026.
We continued monitoring to confirm stable processing before resolving the incident.

Solutions

We are implementing the following measures to prevent recurrence:

  • Decouple fiscal processing

    • Introduce a new table to separate fiscal record ingestion from downstream processing, reducing the risk of database bottlenecks blocking fiscalization.
  • Improve alerting

    • Enhance fiscalization job alerts so repeated timeouts trigger immediate investigation, with a focus on markets where operations can be fully blocked.
  • Strengthen monitoring and resilience

    • Continue improving monitoring and query performance to detect and mitigate similar issues earlier.
Posted Apr 15, 2026 - 11:18 CEST

Resolved

We are no longer seeing any problems with fiscalization jobs in production, printing of fiscalized bills should be working normally now
Posted Apr 09, 2026 - 11:05 CEST

Monitoring

We have unblocked jobs for printing fiscalized bills both for Germany and France, we are now in contacts with properties to confirm the issue has been resolved
Posted Apr 09, 2026 - 09:52 CEST

Investigating

We are currently investigating an issue affecting some properties, where invoices cannot be printed due to a Fiscal Registry error message.
Posted Apr 09, 2026 - 08:18 CEST