Channel manager not receiving reservations, payment processing is impacted as well

Incident Report for Mews

Resolved

The root cause—an outage on our partner PCI Proxy’s side—has been resolved. We’ve recovered the missing reservations from Booking.com and will contact affected partners. If you’re still missing any reservations from this timeframe, please manually push them from your intranet to ensure proper delivery to Mews. We apologize for the inconvenience caused.
Posted Jun 21, 2025 - 09:43 CEST

Update

We are recovering reservations for booking.com direct integration as well we will be reaching out to affected partners to perform a retry operation if it hadn't already been done. However, if you're still missing any reservations from this timeframe, please manually push them from your intranet to ensure they are properly delivered to Mews. We apologize for the inconvenience caused.
Posted Jun 21, 2025 - 07:28 CEST

Monitoring

We can confirm payments are being processed and channel manager reservation are being received. We are monitoring the situation.
Posted Jun 21, 2025 - 06:10 CEST

Update

We are not able to contact PCI Proxy
and the issue still persists.

We can not process payments and we are not receiving reservations through Channel Manger.
Posted Jun 21, 2025 - 03:13 CEST

Update

To reduce impact of the incident, payment automation is paused and the scheduled payments will be processed later.
Posted Jun 21, 2025 - 02:45 CEST

Update

PCI proxy is experiencing issues.
We are trying to contact them to provide solution.
Posted Jun 21, 2025 - 02:37 CEST

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 21, 2025 - 02:20 CEST

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 21, 2025 - 01:47 CEST

Investigating

We have noticed a drop in received reservations.
Also issues with payment processing.
Investigation is in progress.
Posted Jun 21, 2025 - 01:33 CEST
This incident affected: Mews Payments.